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OverviewOverview

 Blending Equation
 Blend Factors & Mode
 Transparency
 Creating an Alpha Channel Using DX Tex Tool
 Render Semi-Transparent Objectsp j

Blending EquationBlending Equation

 Blending
 Allows us to blend (combine) the original pixels that we are 

currently rasterizing with the destination pixels that were 
previously rasterized to the back bufferpreviously rasterized to the back buffer.

 If Pij is the source pixel we are currently rasterizing, then Pij is 
blended with the previous ij-th destination pixel on the back 
b ff bbuffer bij.

 Blending Rule
1 Draw an object with no blending (i e Opaque)1. Draw an object with no blending (i.e., Opaque)
2. Sort blending objects according to the depth from the 

camera (In viewing space, sort objects by z)
3. Draw objects in the back to front order.

Blending EquationBlending Equation

 Blending Equationg q
outputPixel = srcPixelsrcBlendFactor (blendFunction)      

dstPixeldstBlendFactor
 outputPixel: the resulting blended pixel
 srcPixel: the pixel currently being computed that is to be 

blended with pixel on the back buffer specified by theblended with pixel on the back buffer, specified by the 
ColorSourceBlend property

 dstPixel: the pixel currently on the back buffer, specified by the 
C l D ti ti Bl d tColorDestinationBlend property

 srcBlendFactor & dstBlendFactor: [0,1]
 The blend function is specified by the ColorBlendFunction and The blend function is specified by the ColorBlendFunction and 

the AlphaBlendFunction property. The default is 
BlendFunction.Add, and the formula becomes
t tPi l Pi l Bl dF t d tPi ld tBl dF toutputPixel = srcPixelsrcBlendFactor + dstPixeldstBlendFactor



Blending EquationBlending Equation

 Blend Type

Blend type Blend settings

l h l di
(source × Blend SourceAlpha) + (destina

Alpha Blending
(source × Blend.SourceAlpha) + (destina
tion × Blend.InvSourceAlpha) 

Additive Blending
(source × Blend.One) + (destination × Bl

d O
Additive Blending

end.One) 

Multiplicative Blending
(source × Blend.Zero) + (destination × B
lend SourceColor)lend.SourceColor) 

2X Multiplicative Blending
(source × Blend.DestinationColor) + (de
stination × Blend.SourceColor)

Blending EquationBlending Equation

 Enable/disable blending
 Blending is disabled, by default
 Blending is not a cheap operation and should only be enabled for 

the geometry that needs itthe geometry that needs it.
 When you are done rendering that geometry, you should disable 

blending.
 Also, try to batch triangles that use blending and render them at 

once, so that you can avoid turning blending on and off multiple 
times per frame.times per frame.

Blending EquationBlending Equation

 SpriteBatch class – enabling/disabling blending
spriteBatch.Begin()
spriteBatch.Begin(SpriteSortMode.Deferred, BlendState.Opaque)

it B t h B i (S it S tM d B kT F t Bl dSt t Additi )spriteBatch.Begin(SpriteSortMode.BackToFront, BlendState.Additive)
spriteBatch.Begin(SpriteSortMode.BackToFront, BlendState.AlphaBlend)

 BasicEffect class – enabling/disabling blending BasicEffect class – enabling/disabling blending
// enabling
GraphicsDevice.BlendState = BlendState.AlphaBlend;p p ;
GraphicsDevice.DepthStencilState = DepthStencilState.None;
// draw semi-transparent object
basicEffect.Alpha = 0.5f;
drawTransparentObject();
// disabling// disabling
GraphicsDevice.BlendState = BlendState.Opaque;
GraphicsDevice.DepthStencilState = DepthStencilState.Default;

Blend FactorsBlend Factors

 Source and destination blend factors are specified
http://msdn.microsoft.com/en-

us/library/microsoft.xna.framework.graphics.blend(v=xnagamestudio.40)

Blend Zero (0 0 0 0)Blend.Zero (0, 0, 0, 0)

Blend.One (1, 1, 1, 1)

Blend.SourceColor (rs, gs, bs, as)

Blend.InverseSourceColor (1-rs, 1-gs, 1-bs, 10as)

Blend.SourceAlpha (as, as, as, as) srcFactor의 default

Blend InverseSourceAlpha (1-a 1-a 1-a 1-a ) dstFactor의 defaultBlend.InverseSourceAlpha (1-as, 1-as, 1-as, 1-as) dstFactor의 default

Blend.DestinationAlpha (ad, ad, ad, ad)

Blend.InverseDestinationAlpha (1-ad, 1-ad, 1-ad, 1-ad)

Blend.DestinationColor (rd, gd, bd, ad)

Blend.InverseDestinationColor (1-rd, 1-gd, 1-bd, 1-ad)

Blend.SourceAlphaSaturation (f, f, f, 1), f = min(as, 1-ad)Blend.SourceAlphaSaturation (f, f, f, 1), f  min(as, 1 ad)



Blend FactorsBlend Factors
// set the source & destination blend factors directly in an effect file
pass P0pass P0 
{ 

vertexShader = compile vs_2_0 VS(); 
i lSh d il 2 0 PS()pixelShader = compile vs_2_0 PS(); 

AlphaBlendEnable = true; 
SrcBlend = One; 
DestBlend = One;
BlendOp = RevSubtract; p

}; 

Blend FactorsBlend Factors
// alpha blending
pass P0pass P0 
{ 

vertexShader = compile vs_2_0 VS(); 
i lSh d il 2 0 PS()pixelShader = compile vs_2_0 PS(); 

// Use these states to blend RGB components
AlphaBlendEnable = true; 
SrcBlend = One; 
DestBlend = One;
BlendOp = RevSubtract; 

// Use these states to blend the alpha components// Use these states to blend the alpha components
SeparateAlphaBlendEnable = true;
SrcBlendAlpha = SrcAlpha; 
DestBlendAlpha = InvSrcAlpha;DestBlendAlpha = InvSrcAlpha;
BlendOpAlpha = Add; 

}; 

Blend Factors Example 1Blend Factors Example 1

 No blending
 Want to keep the original destination pixel exactly as it is and not 

overwrite or blend it with the source pixel currently being 
rasterizedrasterized

 Set the source pixel blend factor to ZERO and the destination 
pixel blend factor to ONE.

 OutputPixel = SourcePixel ⊗ SourceBlendFactor + DestPixel ⊗
DestBlendFactor

 OutputPixel = SourcePixel ⊗ (0, 0, 0, 0) + DestPixel ⊗ (1, 1, 1, 1) OutputPixel  SourcePixel (0, 0, 0, 0) + DestPixel (1, 1, 1, 1)
 OutputPixel = (0, 0, 0, 0) + DestPixel
 OutputPixel = DestPixel

Blend Factors Example 2Blend Factors Example 2

 Additive blending
 Want to directly add them together to form a new image 
 Set the source pixel blend factor to ONE and the destination pixel 

blend factor to ONEblend factor to ONE.
 OutputPixel = SourcePixel ⊗ SourceBlendFactor + DestPixel ⊗

DestBlendFactor
 OutputPixel = SourcePixel ⊗ (1, 1, 1, 1) + DestPixel ⊗ (1, 1, 1, 1)
 OutputPixel = SourcePixel + DestPixel



Blend Factors Example 3Blend Factors Example 3

 Multiply blending
 Want to multiply a source pixel with its corresponding destination 

pixel
 Set the source pixel blend factor to ZERO and the destination Set the source pixel blend factor to ZERO and the destination 

pixel blend factor to SRCCOLOR.
 OutputPixel = SourcePixel ⊗ SourceBlendFactor + DestPixel ⊗

DestBlendFactor
 OutputPixel = SourcePixel ⊗ (0, 0, 0, 0) + DestPixel ⊗ SourcePixel
 OutputPixel = DestPixel ⊗ SourcePixel OutputPixel = DestPixel ⊗ SourcePixel

Blend Factors Example 4Blend Factors Example 4

 Alpha blending
 Want to blend the source and destination pixels based on the 

transparency percent of the source pixel
 set the source pixel blend factor to SRCALPHA and the set the source pixel blend factor to SRCALPHA and the 

destination pixel blend factor to INVSRCALPHA.
 OutputPixel = SourcePixel ⊗ SourceBlendFactor + DestPixel ⊗

DestBlendFactor
 OutputPixel = SourcePixel ⊗ (sa, sa, sa, sa) + DestPixel ⊗ (1 - sa, 1 -

sa, 1 - sa, 1 - sa)sa, 1 sa, 1 sa)
 OutputPixel = sa · SourcePixel + (1 - sa) · DestPixel

TransparencyTransparency

 Transparency
 To add alpha information to a texture, we create a fourth 

channel called the alpha channel (transparency).
 Alpha channel [0 255]: Alpha channel [0, 255]:

opacity: alpha 0 - 0% transparent
alpha 128 - 50% half transparentp p
alpha 255 - 100% opaque

 If we want to use the texture alpha to set transparency of 
bj t t Al h Bl diobject, set Alpha Blending.

Alpha ChannelAlpha Channel

 Alpha channel
 Alpha value: (1) calculate it during shading process, (2) obtain 

it from the texture alpha channel.
 Alpha channel (RGBA): By using a texture we can control the Alpha channel (RGBA): By using a texture we can control the 

transparency of an object at the pixel level, and we can have 
very complicated patterns of alpha values.

+ =

RGB channel Alpha channel Result



Creating Alpha Channel Using DX Tex ToolCreating Alpha Channel Using DX Tex Tool

 Create a DDS image file (containing alpha channel)
 Run DirectX9 SDK Texture Tool
 Run Program-> Microsoft DirectX 9.0 SDK Update (Feb 2010)-> 

DirectX Utilities > DirectX Texture ToolDirectX Utilities-> DirectX Texture Tool
 Add the alpha channel

 File->Open <crate.jpg> (originally, 24-bit RGB)
 Format->Change Surface Format to be 32-bit A8R8G8B8로 변경

Creating Alpha Channel Using DX Tex ToolCreating Alpha Channel Using DX Tex Tool

 Create a DDS image file (containing alpha channel)
 Add the alpha channel in the image file

 Prepare for 8 bit grey-scale image (e.g., alphachannel.bmp)
 Load alphachannel bmp (8 bit grey scale) by File >Open Onto Load alphachannel.bmp (8-bit grey-scale) by File->Open Onto 

Alpha Channel Of This Texture
 Save ‘createwalpha.dds’ by File->Save As

Render Semi-TransparencyRender Semi Transparency

 Crate Box (alpha=0.5) & xna_logo Box (alpha=1)
 Danc_princess Quad (alpha=0.5) & nice Quad (alpha=1)

Render Semi-TransparencyRender Semi Transparency

protected override void Draw(GameTime gameTime)
{{
… // 중간생략

// Enable alpha blending. p g
GraphicsDevice.BlendState = BlendState.AlphaBlend;
GraphicsDevice.DepthStencilState = DepthStencilState.None;

// [...] Set effect parameters
basicEffect.Alpha = 0.5f;
// draw cube with BasicEffect 
drawCube();

// Disable alpha blending. 
GraphicsDevice.BlendState = BlendState.Opaque;
G hi D i D thSt ilSt t D thSt ilSt t D f ltGraphicsDevice.DepthStencilState = DepthStencilState.Default;

} 



Render Semi-TransparencyRender Semi Transparency

 Ship Model (alpha=0.5) & p1_wedge Model (alpha=1)

Render Semi-TransparencyRender Semi Transparency

private void DrawModel(Model m) {
//// save current states
BlendState bs = GraphicsDevice.BlendState;
DepthStencilState dss = GraphicsDevice.DepthStencilState;p p p
// set for transparencies
GraphicsDevice.BlendState = BlendState.AlphaBlend;
GraphicsDevice DepthStencilState = DepthStencilState Default;GraphicsDevice.DepthStencilState = DepthStencilState.Default;
GraphicsDevice.SamplerStates[0] = SamplerState.LinearWrap;
// draw 3D model with BasicEffect
Matrix[] transforms = new Matrix[m.Bones.Count];
m.CopyAbsoluteBoneTransformsTo(transforms);
foreach (ModelMesh mesh in m.Meshes) {foreach (ModelMesh mesh in m.Meshes) {

foreach (BasicEffect effect in mesh.Effects) {
effect.EnableDefaultLighting();
ff t Al h 0 5feffect.Alpha = 0.5f;

Render Semi-TransparencyRender Semi Transparency

effect.View = view;
ff P j i j ieffect.Projection = projection;

effect.World = 
Matrix.CreateFromYawPitchRoll(MathHelper.ToRadians(90), 45.0f, 0.0f) * 

f fMatrix.CreateTranslation(0, 0, zoom) * Matrix.CreateScale(0.002f, 0.002f, 
0.002f) * transforms[mesh.ParentBone.Index] * 
Matrix.CreateTranslation(modelPosition);

}
mesh.Draw();

}}

// reset blending states
G hi D i Bl dSt t bGraphicsDevice.BlendState = bs;
GraphicsDevice.DepthStencilState = dss;

}

Render Semi-TransparencyRender Semi Transparency



SaveStateModeSaveStateMode

 If you are mixing 3D rendering with 2D objects using 
SpriteBatch, you may notice that your 3D graphics no 
longer draw correctly after you have rendered sprites. 
Thi i b S i B h h d i This is because SpriteBatch changes device states
 GraphicsDevice.BlendState = BlendState.AlphaBlend;
 GraphicsDevice DepthStencilState = DepthStencilState None; GraphicsDevice.DepthStencilState = DepthStencilState.None;
 GraphicsDevice.RasterizerState = 

RasterizerState.CullCounterClockwise;
 GraphicsDevice.SamplerStates[0] = SamplerState.LinearClamp;

 So, you need to reset the device states
 GraphicsDevice.BlendState = BlendState.Opaque;
 GraphicsDevice.DepthStencilState = DepthStencilState.Default;
 GraphicsDevice SamplerStates[0] = SamplerState LinearWrap; GraphicsDevice.SamplerStates[0] = SamplerState.LinearWrap;

SaveStateModeSaveStateMode

struct SaveStateMode {
Bl dS Bl D hS ilS D hSBlendState m_Blenstate;            DepthStencilState m_DepthState;
RasterizerState m_RasterState;           SamplerState m_SamplerState;
GraphicsDevice m_Device;p
public SaveStateMode(GraphicsDevice device) {

m_Device = device; 
m Blenstate = m Device BlendState;m_Blenstate = m_Device.BlendState;
m_DepthState = m_Device.DepthStencilState;
m_RasterState = m_Device.RasterizerState;
m_SamplerState = m_Device.SamplerStates[0];

} 
public void Restore() {public void Restore()  {

m_Device.BlendState = m_Blenstate;
m_Device.DepthStencilState = m_DepthState;

D i R t i St t R t St tm_Device.RasterizerState = m_RasterState;
m_Device.SamplerStates[0] = m_SamplerState;

}        }

SaveStateModeSaveStateMode

protected override void Draw(GameTime gameTime) {
// 중간 생략// 중간 생략…

// draw 3D model
DrawModel(world, view, projection, myModel);p j y
// save state
SaveStateMode mode = new SaveStateMode(GraphicsDevice);
// draw sprite// draw sprite
spriteBatch.Begin(SpriteSortMode.Deferred, BlendState.AlphaBlend);
Color imageColor = Color.White;
imageColor.A = 70;
spriteBatch.Draw(myTexture, new Rectangle(0, 0, myTexture.Width*2, 

myTexture.Height*2), imageColor);myTexture.Height 2), imageColor);
spriteBatch.End();
// and then state restore

d R t ()mode.Restore();
base.Draw(gameTime);

}


