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Spring MVC Setting

0o Spring MVC Quick Start
= OpenJDK 15.0.2 & Eclipse IDE 2020-12

m Tomcat 9.043

Eclipse Server Setting: Eclipse -> Window -> Preferences -> Server ->
Runtime Environments -> Tomcat9

= Common Logging 1.2

https://commons.apache.org/proper/commons-
logging/download_logging.cqi

Download commons-logging-1.2-bin.zip

= Maven 3.6.3 E=ME 2|z
https://maven.apache.org/download.cqgi
Download apache-maven-3.6.3-bin.zip

m Spring Tool Suite (STS)
https://spring.io/tools/ Spring Tools for Eclipse

Install Eclipse->Help->"Eclipse Marketplace” -> STS -> Spring Tools
3.9.14 RELEASE



Commons Logging

O https://commons.apache.org/proper/commons-
logging/download_logging.cgi S

ommons.apache.org/proper/commons-loggin veead_loggin: ﬁh = ® 2
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Gommens

Apache Commons "

http://commons. apache.org/

:1.2 ApacheGon Ap:

shed: 09 July 2014 |
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Download Apache Commons Logging

Using a Mirror

We recommend you use a mirror to download our release builds, bul you must verify the integrity of the downloaded files using signatures downloaded from our main distribution directories. Recent releases (48 hours) may

not yet be available from the mirmors.

You are currently using https:/idownioads.apache.orgl. If you encounler a problem with this mirror, please select another mirror. If all mirrors are failing, there are backup mirrors (at the end of the mirrors list) that should
be available.

Other mirrors: _ hitips:/idownlcads.apache.org ™ [ change

checksum files).

Itis essential that you verify the integrily of downloaded files, preferably using the Fe signalure ( *.asc files); failing that using the hash (=== .=

The KEYS file contains the public PGP keys used by Apache Gommons developers to sign releases

Apache Commons Logging 1.2

Binaries

ing-1.2-bin.ar.gz sha2s6

commans-log

ng-1.2-bin.z

Source

ing-1.2-src.targz

commens-logging-1.2-src.zip sha2s6 pop

Archives

Older releases can be obtained from the archives.

+ browse cownload area

+ archives.




Maven

O https://maven.apache.org/download.cg

© #  Maven - Download Apache Mav X | ==

< C @ & Notsecure | mavenapache.org/download.cqi#

G ¢+ @ 2

Apache Maven Project M ' -
= http:f/maven.apache.org/ aven

Download | Get Sources | Last Published: 2021-04-03

Apache ' Maven

Welcome Downloading Apache Maven 3.6.3

License
Apache Maven 3.6.3 is the latest release and recommended version for all users.

SECAve The currently selected download mirror is https:/idownloads.apache.orgl. If you encounter a problem with this mirrer, please select another mirror. If all mirrors are failing, there are backup

What is Maven? mirrars (at the end of the mirrors list) that should be available. You may also consult the complete list of mirrors.
Feat
catres Other mirrors: | hitpsi//downloads.apache.org. v Change
(o]
Use
Release Notes System Requirements

DOCUMENTATION
Java Development  Maven 3.3+ require JOK 1.7 or above to execute - they still allow you to build against 1.3 and other JDK versions by Using Toolchains
Maven Plugins Kit (JDK)
Index (category)
Memory No minimum requirement
User Centre
Plugin Developer Centre Disk Approximately 10MB is required for the Maven installation itsslf. In addition to that, additional disk space will be used for your local Maven repository. The size of your

Maven Central Repository local repository will vary depending on usage but expect at least 500MB,

Maven Developer Centre Operating System  No minimum requirement. Start up scripts are included as shell scripts and Windows batch files.
Books and Resources

Security

Files

Maven is distributed in several formats for your convenience. Simply pick a ready-made binary distribution archive and follow the installation instructions. Use a source archive if you intend to

wnity Overvi h
GOt brDveL A build Maven yoursaif.

Project Roles

In order to guard against corrupted ions, it is highly ri 1o verify the signature of the release bundles against the public KEYS used by the Apache Maven
How to Contribute
developers.
Getting Help
|ssue Management Link Checksums Signature
Getting Maven Source Binary tar.gz archive apache-maven-3.8.3-bin.tar.gz apache-maven-2.6.3-bin.tar.gz.sha512 apache-maven-3.6.3-bin tar.gz.asc
The Maven Team
Binary zip archive lapache-maven-3 8 3-bin zip apache-maven-3.6.3-bin zip.sha512 apache-maven-3.6.3-bin zip.asc
CT DOCUMENTATION
X Source tar.gz archive apache-maven-3.8.3-src.tar.gz apache-maven-3.6.3-src.largz.sha512 apache-maven-3.6.3-src.tar.gz.asc
Project Information
Source zip archive apache-maven-3 6 3-src.zip apache-maven-3.6.3-sro.zip sha512 apache-maven-3.6 3-src zip asc

Archetype

= Release Notes

= Refersnce Documentation

Doxia = Apache Maven Website As Documentation Archive
JXR = All current release sources (plugins, shared librar
= |atest source code from source repository

= Distributed under the Apache License, version 2.0

Artifact Resolver

) available at https://downloads.apache.org/imaven/

Maven
Parent POMs
Plugins Previous Releases

Plugin Testin
¢ 9 Itis strongly recommended to use the latest release version of Apache Maven to take advantage of newaest features and bug fixes.

Plugin Tools

If you still want to use an old version you can find more information in the Mavan Releases History and can download files from the archivas for versions 3.0.4+ and legacy archives for earier =




aven

/' Maven - Installing Apache Mave X | ==

M a Ve n « C ® & Mot secure | maven.apache.org/install.htm L lh"u = % @

Apache Maven Project M ™

Maven @ Download | Get Sources | Last Published: 2021-02-12

Apache /| Maven

Installing Apache Maven

License
The installation of Apache Maven is a simple process of extracting the archive and adding the "bin’ folder with the "'mvn” command to the "PATH'.

Detailed steps are:;

What is Maven? « Ensure 1ava_wome environment variable is sel and points to your JOK installation

Features = Extract distribution archive in any directory

Download =
1. unzip apache-maven-3.6.3-bin.zip

Use
E -
AL 1. tar xzvf apache-maven-3.6.3-bin.tar.gz
Configure
IDE Integration Altematively use your preferred archive extraction toal.
Support and Training » Addthe bin directory of the created directory apache-maven-1.6.3 to the path environment variable

Releass Not:
s # Confirm with sun v in a new shell. The result should look similar to

UMENTATION

. Apache Maven 3.6.3 ( 265 28837}

. Maven home: /opt/apache-maven-3.5.3

Java version: 1.8.8_45, vendor: Oracle Corporation

. Java home: /Library/Java/JavaVirtualMachines/jdkl.8.8_45.jdk/Contents/Home/jre
. Default locale: en_US, platform encoding: UTF-8

. 05 name: "mac os x", version: "18.8.5", arch: "x86_64", family: "mac"

Maven Plugins
Index (category)

User Centre

[ ST T

Flugin Developer Centre
Maven Cantral
Repository

Windows Tips

Centre » Check environment variable value e.q.

Maven Developer

Books and Resources
1. echo XJAVA_HOMEX

Security 2. C:\Program Files‘Java\jdk1.7.e_51
| ) . = Adding to patu : Add the unpacked distribution’s bin directory to your user PATH environment variable by opening up the system properties (Winkey + Pause), selecting the
| S S “Advanced” tab, and the "Environment Variables™ button, then adding or selecting the PATH variable in the user variables with the value

Project Reles C:\Program Files\apache-maven-3.6.3\bin . The same dialog can be used to set Java_wome to the location of your JOK, e.9. ¢:\Program Files\Java\jdkl.7.e 51

How to Cantribute = Open a new command prompt (Winkey + R then type cmd ) and run mvn -v to verify the installation.

EEL‘Z‘;Z:LZM Unix-based Operating System (Linux, Solaris and Mac OS X) Tips

Getting Maven Source
9 = Check environment variable value
The Maven Team
1. echo $JAVA_HOME

PROJECT DOCUMENTATION 2. /Library/Java/JavaVirtualMachines/jdkl.8.8_45.jdk/Contents/Home

Project Information

= Addinn ta saTu



Maven

0 Unzip apache-maven-3.6.3-bin.zip & Copy “apache-
maven-3.6.3" to "C:#Program FilesWApache Software
Foundation”

[ s | apache-maven-3.6.3-bin

Home Share View o

— wi A « spring.. » apache-maven-3.6.3-bin v O 2 Search apache-maven-3.6.3-bin

¥ 3D Objects & Name Date modified Type Size
Bk apache-maven-2.6.3 2021-02-17 2% 1:23 File folder

=| Documents

¥ Downloads

J’) Music

&= Pictures

ﬁ Videos

% . Local Disk (C3)

v < | Apache Software Foundation

Home Share View 0

<« v 1 <« Local Disk (C:) » Program Files » Apache Scktware Foundation v D O Search Apache Software Foundation
¥ Downloads A Name Date modified Type Size
= D t:
= apache-maven-3.6.3 File folder
= Pictures ¥ commons-logging-1.2 File folder
KyoungPark-AdvancedJavaProgrammir Tomeat 9.0 File folder
spring_slides
video
ﬂ Videos
@ OneDrive
v BThis PC
J 3D Objects
[ Desktop
v

3 items



Maven

O Set path environment variable

New System Variable | Edit environment variable

C:\DevTools\Anaconda3 New
C\DevTools\Anaconda3\Library\mingw-w64\bin
‘ C\DevTools\Anaconda3\Library\usr\bin Edit

C\DevTools\Anaconda3\Library\bin

| - | C\DevTools\Anaconda3\Scripts -
i i TOWSE...
Browse Directory... Browse File... oK Cance CAWindows\system32

C\Windows

Variable name: ‘MAVEN_HOME ‘

Variable value: ‘C:\Program Files\Apache Software Foundation\apache—maven—3.6.3|

CAWindows\System32\Wbem SRzl

C\Windows\System32\WindowsPowerShell\v1.0\
C\Windows\System32\OpenSSHY

C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common Move Up
%JAVA_HOME%\bin
C\Users\park\AppData\Local\Android\Sdk\platform-tools Move Down
C\Program Files\Git\cmd
C\Program Files\dotnet\
C\Program Files (x86)\dotnet\, Edlit toxt.

%MAVEN_HOME%\bin




Maven

O Run “mvn ="




Spring Tool Suite (STS)

O Eclipse -> Help -> Eclipse Marketplace -> Find: STS ->

Spring Tools 3.9.14.RELEASE->Install

Help
& Welcome
@ Help Contents

% Search
Show Contextual Help

Show Active Keybindings... Ctrl+Shift+L

Tip of the Day

#5 Tips and Tricks...
# Report Bug or Enhancement...
Cheat Sheets... Open the Edlipse Marketpla
@ Eclipse User Storage >
“& Perform Setup Tasks...
% Check for Updates
g+ Install New Software...
U Eclipse Marketplace...
@ About Eclipse IDE
® Donate

Contribute

E_.] Eclipse Marketplace O

Eclipse Marketplace

Select solutions to install. Press Install Now to proceed with installation.
Press the "more info" link to learn more about a solution.

Search|Recent Popular|Favorites Installed . Giving loT an Edge

Find: |PSTS x

All Markets ~ | |All Categories b4

x 30 77| Installs: 53.3K (856 last month) Install

Spring Tools 3 Add-On for Spring Tools 4 3.9.16.RELEASE
g' Spring Tools 3 Add-On for Spring Tools 4 Attention: This add-on pack provides additional

| components from the previous Spring Tools 3 generation to be installed... more info
by VMware, EPL
J2EE spring Spring IDE Cloud jee
#  Installs: 406K (7,839 last month)

* 266 Install

Spring Tools 3 (Standalone Edition) 3.9.14.RELEASE
\ Spring Tools 3 (Standalone Edition) The Spring Tools 3 contain the previous generation
| Spring tooling for Eclipse, mostly focused on working with Spring apps... more info
by VMware, EPL
J2EE spring Spring I1DE Cloud jee

*63 A Installs: 149K (12,289 last month) Install
Marketplaces
- 4
=Dl
@ < Back Install Now > Finish Cancel

Go

~




Spring Tool Suite (STS)

O Eclipse -> Help -> Eclipse Marketplace -> Find: STS ->
Spring Tools 3.9.14.RELEASE->Install & Restart Eclipse

8] tdipse Marketplace X
Confirm Selected Features z%
[

Press Confirm to continue with the installation. Or go back to choose more solutions to install.

v §- Spring Tools 3 (Standalone Edition) 3.9.14.RELEASE https://download.springsource.com/release/TOOLS/update/e4.17/
[ 4 Spring IDE Core (required) (required)
% Cloud Foundry Manifest Language Server Feature
% Pivotal tc Server Integration for Eclipse
% Spring Dashboard (optional)
% Spring IDE AJDT Integration (optional)
% Spring IDE AOP Extension (optional)
% Spring IDE Autowire Extension (optional)
[v] 4% Spring IDE Batch Extension (optional)
[v] 4% Spring IDE Boot Microservices Dash
[v]# Spring IDE Boot Support
% Spring IDE Integration, Flex and Web Services Extension (optional)
[v] 4 Spring IDE Maven Support
[v] % Spring IDE Mylyn Integration (opticnal)
% Spring IDE Security Extension (optional)
2¢ Spring IDE Spring Data Support
% Spring IDE Web Flow Extension (optional)

@ < Install More Finish Cancel




Spring Tool Suite (STS)

O Eclipse -> Help -> Eclipse Marketplace -> Find: STS ->
Spring Tools 3.9.14.RELEASE->Install & Restart Eclipse

8] tdipse Marketplace X
Confirm Selected Features z%
[

Press Confirm to continue with the installation. Or go back to choose more solutions to install.

v §- Spring Tools 3 (Standalone Edition) 3.9.14.RELEASE https://download.springsource.com/release/TOOLS/update/e4.17/
[ 4 Spring IDE Core (required) (required)
% Cloud Foundry Manifest Language Server Feature
% Pivotal tc Server Integration for Eclipse
% Spring Dashboard (optional)
% Spring IDE AJDT Integration (optional)
% Spring IDE AOP Extension (optional)
% Spring IDE Autowire Extension (optional)
[v] 4% Spring IDE Batch Extension (optional)
[v] 4% Spring IDE Boot Microservices Dash
[v]# Spring IDE Boot Support
% Spring IDE Integration, Flex and Web Services Extension (optional)
[v] 4 Spring IDE Maven Support
[v] % Spring IDE Mylyn Integration (opticnal)
% Spring IDE Security Extension (optional)
2¢ Spring IDE Spring Data Support
% Spring IDE Web Flow Extension (optional)

@ < Install More Finish Cancel




Eclipse Spring Legacy Project

O Eclipse -> File -> New -> Other -> Spring -> Spring
Legacy Project ->Project name & Templates: Spring
MVC Project -> package name -> Finish

@ Select a wizard 8] New Spring Legacy Project [m] w
— Spring Legacy Project T —x,
Select a wizard = /e

D Click '"Next' to load the template contents.

Project name: | Springk IcIIo! |

Wizards: [] Use default location
type filter text C\Users\park\e workspace\aj21\SpringHello Browse..
= P|ugfin Deve|0pment A~ Select Spring version: Default
= Server Templates:
) ) w i Simple Projects
v e Sprmg (& Simple Java
4 Spring Bean Configuration File % Simple Spring Maven
. .. Simple Spring Web Ma
@ Spring Bean Definition ) B"l l""p & spring T Maven
’ = patcn
& Spring Legac)" Projed » & GemFire
& Spring Web Flow Definition File > & Integration
. . & Persistence
& Spring Boot % Simple Spring Utility Project
= SQL Development & Spring MVC Project
= Tasks
v
= A ict!
# requires downloading Configure templates,,, Refresh
Description:

A new Spring MVC web application development project
N .
@ < Back Next > Finish Cancel

URL:https://dist.springsource.com/release/STS/help/org springframework templates.mve-3.2.2 zip

Working sets
[_] Add project to working sets Mew...

Select...

@ < Back Finish Cancel



Spring MVC Project

o Spring MVC Project C|AE2| L=

v 2 SpringHello @ Home &
> ~' Deployment Descriptor: SpringHello Com$ ‘http://Ioca|h05t8085fdank00kf
» # Spring Elements
> @ JAX-WS Web Services
> 7 Java Resources Hello World!
> (% Deployed Resources
W 5 - .
- Sr;: _ The time on the server is 20217 4? 4? 7?7 7? 507 4? KST.
v & main
v =kr —l —=— 1
v [=ac
v = dankook
HomeControllerjava [ N =
> [ reSOUICES = E’l—'—— L_'l _IEE'|
v 2 webapp 3
g l View JS, CSS
& classes o] © ol . M E )
v & spring A= flet Spring 2 E
v £ appServlet j
5 servlet-context.xml I . . .
PP — — Spring MVC configuration
v = views E— ' )
home,jsp l V| ew JS P
B web.xmi=———
> = test 1= 9|.| . . .
R =4 configuration file

M pom.xm|=——

-

H O£ configuration file




<properties>

pom.xml

<java-version>15</java-version>
<org.springframework-version>5.2.8.RELEASE</org.springframework-version>
<org.aspectj-version>1.6.10</org.aspectj-version>
<org.slf4j-version>1.6.6</org.slf4j-version>
</properties>
<build>
<plugins>
<plugin>
<groupld>org.apache.maven.plugins</groupld>
<artifactld>maven-compiler-plugin</artifactld>
<version>3.8.1</version>
<configuration>
<source>15</source>
<target>15</target>
<compilerArgument>-Xlint:all</compilerArgument>
<showWarnings>true</showWarnings>
<showDeprecation>true</showDeprecation>
</configuration>
</plugin>
</plugins>

</build> Eclipse Project -> Maven -> Update Project (Update Maven)



home.jsp =&

A

<%@ page language="Java" contentType="text/htmi; charset=UTF-8"
pageEncoding="UTF-8"%>

<%@ taglib uri="http./java.sun.comyjsp/stl/core” prefix="c" %>
<%@ page session="false” %>

<html|>

<head>

<title>Home</title>

</head>

<body>

<h1>

Hello world!

</h1>

<P> The time on the server is ${serverTime}. </P>
</body>
</html>

home.jsp

Eclipse Project -> Run As -> Maven Clean & Maven Install & Run on Server




Spring MVC Project &3

@ Home &

< w | http://localhost:8085/dankook/

Hello world!

The time on the server 1s 20215 4= 42 @ = 8Al 51 1= KST.



HomeController.java %

@cController

HomeController.java

public class HomeController {
private static final Logger /ogger = LoggerFactory.getl ogger(HomeController.class);

@RequestMapping(value = "/", method = RequestMethod. GET)

public String home(Locale locale, Model model) {

logger.info("Welcome home! The client locale is {}.", locale);

Date date = new Date();

DateFormat dateFormat = DateFormat.getDate Timelnstance(DateFormat.LONG,
DatefFormat.LONG, locale);

String formattedDate = dateFormat.format(date);
model.addAttribute("serverTime", formattedDate );
/I add more attribute serverTimeZ} message
String greetings = "Greetings, Spring MVC"; — aMo| 2do] F=7HE
model.addAttribute("message", greetings);
return "home";

}




home.jsp =&

A

<%@ page language="Java" contentType="text/htmi; charset=UTF-8"
pageEncoding="UTF-8"%>

<%@ taglib uri="http./java.sun.comyjsp/stl/core” prefix="c" %>
<%@ page session="false” %>

<html|>

<head>

<title>Homex</title>

</head>

<body>

<h1>

Hello world! ${message}

</h1>

<P> The time on the server is ${serverTime}. </P>
</body>
</html>

home.jsp

Eclipse Project -> Run As -> Maven Clean & Maven Install & Run on Server




Spring MVC Project &3

@ Home

<" ¥ | http://localhost:8085/dankook/

Hello world! Greetings, Spring MVC

The time on the server1s 20215 52 7 @ & 10A| 44 29= KST.
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AZR MVC 8 11

o web.xmlOf| DispatcherServlet 278
= O 32 JZ0| o 7|Ss(HEED) 2 AKX

o webxml O 7HEIH Q13 HH 47

o 2T MVC 23

= HandlerMapping, HandlerAdapter 2 ge==)
= ViewResolver 878




DispatcherServiet &%

n AEELH 0| @ )
HHOIE M AZEl AHEHO|HE Al M

s ZAH|O|H A™ oY Z2 = /WEB-INF/Al= &l 0| £ -servlet.xmlO|

2 4R

» 28 It 55 UE7| fISA= contextConfiglocation
O 70 H =5 web.xml0f X|7H

ﬂJI

<!-- Processes application requests -->
<servlet>
<servlet-name>appServlet</servlet-name>

web.xml

<servlet-class>org.springframework.web.servlet.DispatcherServlet</servlet-class>

<init-param>
<param-name>contextConfigLocation</param-name>

<param-value>/WEB-INF/spring/appServlet/servlet-context.xml</param-value>

</init-param>
<load-on-startup>1</load-on-startup>
</servlet>




DispatcherServiet &%

O servlet-context.xm| 2+©l

servlet-context.xmil

<!-- DispatcherServlet Context: defines this servlet's request-processing
infrastructure -->

<!-- Enables the Spring MVC @Controller programming model -->
<annotation-driven />

<!-- Handles HTTP GET requests for /resources/** by efficiently serving up static
resources in the ${webappRoot}/resources directory -->

<resources mapping= "Jresources/**" location="/resources/” />

<!-- Resolves views selected for rendering by @Controllers to .jsp resources in the
/WEB-INF/views directory -->

<beans:bean

class= "org.springframework.web.servlet.view.InternalResourceViewResolver”>
<beans:property name= "prefix"” value="yWEB-INF/views/" />
<beans:property name= "suffix” value="/sp" />

</beans:bean>

<context.component-scan base-package= "krac.dankook” />



HEE 3T EE 278

L

o ot= 2AIEL ME IO/ (localhost/ArE X)) X 2| =
@) @)

o web.xml2| webapp Ef 1 L{O|| Ct= L& =7}

<filter>
<filter-name>encodingFilter < /filter-name>
<filter-class>org.springframework.web filter.CharacterEncodingFilter < /filter-class >
<init-param>
<param-name>encoding</param-name>
<param-value>UTF-8</param-value>
</init-param>
</filter>
<filter-mapping>
<filter-name>encodingFilter < /filter-name>
<url-pattern>/*</url-pattern>
</filter-mapping>



MVC 14242 2% (servlet-context.xml)

o HandlerMapping, HandlerAdapter, ViewResolver 273
o WS OHHeF OEE AHE2 HHE22 S &
- @Controller O'll'EElOlElE E'EHJ\E 9452; A|'c> = —T— %I&E%

<l-- Enables the Spring MVC @Controller programming model -->
<annotation-driven />

F

[ok

servlet-context.xml

o & 2|EH = Ol E Solf +¢
= /web-inf/views/ Ol2flQ| jsp LWUSS HE ALE

<!-- Resolves views selected for rendering by @Controllers to .jsp resources
in the /WEB-INF/views directory -->

<beans:bean

class= "org.springframework.web.serviet.view.InternalResourceViewResolver">
<beans:property name= "prefix" value="yWEB-INF/views/" />
<beans:property name= "suffix" value=";sp" />

</beans:bean>



=d| 4= i EI2Y) (web.xml)

o ArEXA7E ot B 20| CHol appServiet AE

“do 9 20| BRI 7|58 B A2

= Jusers/* 2F Z0| ZE2| O|F2 2 7|52 €Yot &
e ZE= ®H ZE20 CHdl appServiets &S

jsp 28 7(1|9|°* LIHX] 2= 28-S appServletO|
ATE mve BEINY 0| <mvcdefault-serviet-handler /

x71510] E700| 40428 H[O|X[E AZZ0| $E 2

ol
PN =]

<servlet-mapping>
<servlet-name>appServlet</servlet-name>

<url-pattern>/</url-pattern>
</servlet-mapping>

10

al
HF
—

2 39

Vv
dunn pn olo
ot
>

|.|-|

o)



HEER ¥

@Controller 04 E{|0|M

HomeController.java

public class HomeController {
private static final Logger /ogger = LoggerFactory.getl ogger(HomeController.class);

@RequestMapping(value = "/", method = RequestMethod. GE7) A= 0OHE
public String home(Locale locale, Model model) {

logger.info("Welcome home! The client locale is {}.", locale);

Date date = new Date();

DateFormat dateFormat = DateFormat.getDate Timelnstance(DateFormat.LONG,
DatefFormat.LONG, locale);

String formattedDate = dateFormat.format(date);

model.addAttribute("serverTime", formattedDate ); ~ 22l cllolE F7t
// add more attribute serverTimeZ} message
String greetings = "Greetings, Spring MVC"; — aMo| 2do] F=7HE
model.addAttribute("message", greetings);

return "home"; Y 0O|E Z|EA

}



