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Spring MVC Setting

o Spring MVC Quick Start
= JDK 11.0.2 & Eclipse IDE 2021-12

m Tomcat 9.0.58

Eclipse Server Setting: Eclipse -> Window -> Preferences -> Server ->
Runtime Environments -> Tomcat9

= Common Logging 1.2

https://commons.apache.org/proper/commons-
logging/download_logging.cgi

Download commons-logging-1.2-bin.zip

= Maven 3.8.1 ZE2ME 2| =5 maven-war-plugin 3.3.1
https://maven.apache.org/download.cqgi
Download apache-maven-3.8.1-bin.zip

m Spring Tool Suite (STS) 5.2.8.RELEASE
https://spring.io/tools/ Spring Tools for Eclipse

Install Eclipse->Help->"Eclipse Marketplace” -> STS -> Spring Tools
3.9.14 RELEASE



Commons Logging

O https://commons.apache.org/proper/commons-
logging/download_logging.cgi

(im] / Apache Commons Logging - Do X | -

- [ x

< C » (2] https//commons.apache.org/proper/commens-logging/download_logging.cgi - A I -

: commons
Apache Commons logglng

http://commons. apache.org/

Apache Commons Loggmg ™ Last Published: 09 July 2014 | Version: 1.2 ApacheCon Apache Commons

COMMONS LOGGING Download ApaChe Commons Logging

Overview

Download

Veer @i Using a Mirror

Troubleshooting Guide

Release Notes We recommend you use a mirror to download our release builds, but you must verify the integrity of the downloaded files using signatures

JavaDoc (Latest release) downloaded from our main distribution directories. Recent releases (48 hours) may not yet be available from the mirrors

JavaDoc (v1.1.3) You are currently using https://dicdn.apache.org/. If you encounter a problem with this mirror, please select another mirror. If all mirrors are

JavaDoc (v1.0.4) failing, there are backup mirrors (at the end of the mirrors list) that should be available

£ DEVELOPMENT
Building Other mirrors:  hitps://dicdn.apache.org/ v

Mailing Lists

Issue Trackin
2 Itis essential that you verify the integrity of downloaded files, preferably using the pGE signature ( *.asc files); failing that using the sEA256

Proposal hash ( *>+.sha256 checksum files)
Tech Guide
Wiki The KEYS file contains the public PGP keys used by Apache Commons developers to sign releases

JavaDoc (SVN latest)

Apache Commons Logging 1.2

© PROJECT DOCUMENTATION

» Project Information

» Project Reports B| naries
COMMONS
commons-logging-1.2-bin.tar.gz sha256 pap
Home
License commens-logging-1.2-bin.zip sha256 pap

» Components

hitpsi// h Sgi html -




Maven

O https://maven.apache.org/download. cg|

m]
&

/' Maven - Download Apache Ma

x |+ u}

C @ ) https//maven.apache.org/download.cgi A G e W O = 3

M Apache Maven Project

™
ttp://maven.apache.org/ aven

Apache / Maven / Dow

Welcome

License

ABOUT MAVEN
What is Maven?

Features

Use

Release Notes

DOCUMENTATION
Maven Plugins
Maven Extensions
Index (category)
User Centre

Plugin Developer
Centre

Maven Central
Repository

Maven Developer
Centre

Books and
Resources

Security

COMMUNITY

Download | GetSources | Last Published: 2022-05-02

Downloading Apache Maven 3.8.5

Apache Maven 3.8.5 is the latest release and recommended version for all users.

The currently selected download mirror is https://dlcdn.apache.org/. If you encounter a problem with this mirror, please select another
mirror. If all mirrors are failing, there are backup mirrors (at the end of the mirrors list) that should be available. You may also consult the
complete list of mirrors.

Other mirrors:  https://dicdn.apache.org/ v

System Requirements

Java Development Maven 3.3+ require JDK 1.7 or above to execute - they still allow you to build against 1.3 and other JDK versions
Kit (JDK) by Using Toolchains

Memory No minimum requirement

Disk Approximately 10MB is required for the Maven installation itself. In addition to that, additional disk space will be
used for your local Maven repository. The size of your local repository will vary depending on usage but expect at
least 500MB.

Operating System No minimum requirement. Start up scripts are included as shell scripts and Windows batch files.

Files

Maven is distributed in several formats for your convenience. Simply pick a ready-made binary distribution archive and follow the installation
instructions. Use a source archive if you intend to build Maven yourself.

In order to guard against corrupted downloads/installations, it is highly recommended to verify the signature of the release bundles against

x




Maven

O Maven

x  + _ O
U &=

0 | / Maven- Installing Apache Mave

& C M &) https://maven.apache.org/install.html A T8 g

Apache Maven Project

/Mtp //maven.apache.org/

Apache / Maven

Welcome

License

ABOUT MAVEN
What is Maven?
Features
Download
Use

Run

Configure

IDE Integration

Support and
Training

Release Notes

DOCUMENTATION
Maven Plugins
Maven Extensions
Index (category)
User Centre

Plugin Developer
Centre

Maven Central
Repository

Installing Apache Maven (@

Maven

Download | Get Sources | Last Published: 2022-05-02

Installing Apache Maven

The installation of Apache Maven is a simple process of extracting the archive and adding the bin folder with the mvn command to the
PATH .

Detailed steps are:

= Have a JDK installation on your system. Either set the Java_HoMe environment variable pointing to your JDK installation or have the
java executable on your PATH .

= Extract distribution archive in any directory

‘ 1. unzip apache-maven-3.8.5-bin.zip

or

‘ 1. tar xzvf apache-maven-3.8.5-bin.tar.gz

Alternatively use your preferred archive extraction tool.
= Add the bin directory of the created directory apache-maven-3.8.5 tothe PATH environment variable

= Confirm with mvn -v in a new shell. The result should look similar to

. Apache Maven 3.8.5 (3599d34141046de2324203b78ddcf9b5e4388aa0)

1

2. Maven home: /opt/apache-maven-3.8.5

3. Java version: 1.8.8_45, vendor: Oracle Corporation

4. Java home: /Library/Java/JavaVirtualMachines/jdkl.8.0_45.jdk/Contents/Home/jre
5. Default locale: en_US, platform encoding: UTF-8

6. 0S name: "mac os x", version: "10.8.5", arch: "x86_64", family: "mac"

Windows Tips




Maven

0 Unzip apache-maven-3.8.5-bin.zip & Copy “apache-
maven-3.8.5" to "C:WProgram FilesWApache Software

! [ = d t’ 1/
Nnaation
| . L
| « v 4 “ |lab » apache-maven-3.8.5-bin v O Search apache-maven-3.8.5-bin
[ ~ Mame Date modified Type Size
| 7 Quick access
apache-maven-3.8.5 2022-05-11 2% &:02 File folder
| &% Dropbox
.dropbox.cache
@ c920-hw
@ Motability
@ OneDrive - Personal
= This PC
J 3D Objects
| [ Desktop
é Documents v
1itern 1 item selected
(= = | Apache Software Foundation
Home Share WView
« v <« Local Disk (C:) » Program Files * Apache Softwarf| Foundation v | D Search Apache Software Foundation
" Mame Date modified Type Size
7 Quick access ‘¥
apache-maven-3.8.3 File folder
e
&* Dropbox commons-logging-1.2 File folder
.dropbox.cache Torncat 9.0 File folder
@ | cg20-hw Tomecat 10.0 File folder

@ Notability
@ OneDlrive - Personal

[ This PC
M 30 Obiects



Maven

0O Set path environment variable

Mew Systemn Variable Edit environment variable

C\DevTools\Anaconda3 New
Variable name: | MAVEM_HOME C:\DevTools\Anaconda3\Librany\mingw-w64\bin
C\DevTools\Anaconda3\Library\usr\bin
Variable value: | ChProgram Files\Apache Software Fn:-undatin:nn\apache-r‘naven-B.E.S{ C\DevTools\Anaconda3\Library\bin
C\DevTools\Anaconda3\Scripts
C\Windows\system32

C\Windows

Edit

Browse...

Browse Directory... Browse File... 0K

Delete

C\Windows\System32\Wbem
C\Windows\System32\WindowsPowerShell\v1.0\
C\Windows\System32\OpenSSHY

C\Program Files (x86)\NVIDIA Corporation\PhysX\Common Move Up
%JAVA_HOME%%\bin
C\Users\park\AppData\l ocal\Android\Sdk\platform-tools Move Down
C\Program Files\Git\cmd
C\Program Files\dotnet\
C\Program Files (x86)\dotnet\ Edlit text.

%MAVEN_HOME%\bin




O Run "mvn =v"

Command Prompt




Spring Tool Suite (STS)

O Eclipse -> Help -> Eclipse Marketplace -> Find: STS ->
Spring Tools 3 (Standalone Edition) 3.9.14.RELEASE ->Instal

Help

8] Eclipse Marketplace O x
T
s Welcome Eclipse Marketplace
B Select solutions to install. Press Install Mow to proceed with installation.
|€) H elp antents Press the "more infe" link to learn more about a selution,
7 Search | Recent | Popular| Favorites | Installed | |, Giving loT an Edge
% Search
Find: |PSTSl | | All Markets ~ | |All Categories ~| | Go
Show Contextual Help -

Spring Tools 3 (Standalone Edition) 3.9.14.RELEASE

| Spring Tools 3 (Standalone Edition) Attention - End of life: The Spring Tools 3 are no longer maintained and
| no longer updated for newer Eclipse versions, Please... more info

Show Active Keybindings... Ctrl+Shift+L

s Tip of the Day | by YMware EPL
- . . J2EE spring Spring IDE Cloud jee
“~ Tips and Tricks...
o /% | Installs: 277K (8,674 last month) Install
# Report Bug or Enhancement...
; Spring Tools 3 Add-On for Spring Tools 4 3.9.22 . RELEASE
Cheat ShEEtS"' Dpen the ECleSE MarkEtpla \ Spring Tools 3 Add-On for Spring Tools 4 End of life: This Spring Tecls 3 Add-On for Spring Teols 4is no
| longer maintained or updated. The final and last release.. more info

Eclipse User Storage > | by Mware EPL
. J2EE spring Spring IDE Cloud jee
*? Perform Setup Tasks...

W 323 #% | Installs: 520K (7,822 last month) Install

‘@ Check for Updates
4 Install New Software... Marketplaces
U Edipse Marketplace... e
@ About Eclipse IDE
® Donate

CDntl’ibUte @' < Back Install Mow = Finish Cancel



Spring Tool Suite (STS)

B Eclipse Marketplace O >
Confirm Selected Features %
Press Confirm to continue with the installation. Or go back to choose more solutions to install. H

v [] = Spring Tools 3 {Standalone Edition) 3.9.14.RELEASE https://download.springsource.com/release/TOOLS/update/ed. 17/
ge Spring IDE Core (required] (required)
57 Cloud Foundry Manifest Language Server Feature
o~ Pivotal tc Server Integration for Eclipse
o= Spring Dashbeard (optional]
o Spring IDE AJDT Integration (optional)
o= Spring IDE AQOP Extension (optional)
o= Spring IDE Autowire Extension (optional)
o7 Spring IDE Batch Extension (optional)
57 Spring IDE Boot Microservices Dash
o7 Spring IDE Boot Support
o~ Spring IDE Integration, Flex and Web Services Extension (optional)
o= Spring IDE Maven Support
o= Spring IDE Mylyn Integration (optional)
o= Spring IDE Security Extension (optional)
o= Spring IDE Spring Data Support
o0 Spring IDE Web Flow Extension (optional)

Calculating requiremnents and dependencies.

=
||

@ < Install More Confirm = Finish Cancel




Eclipse Spring Legacy Project

o Eclipse -> File -> New -> Other -> Spring -> Spring
Legacy Project ->Project name & Templates: Spring
MVC Project -> package name -> Finish

. 8] New Spring L Project ul X
E Select a wizard 0 e & New Spring Legacy Projec
Spring Legacy Project —
. Click 'Next'to load the template contents. 2 "
SEIECt a w|z,ard _— < (i) Click 'Mext' to load the template contents. "

Project name: | SpringHelle ‘

Use default location
Wizards:

Ci\Users\park\eclipse-workspace\aj22\SpringHello Browse...
type filter text

Select Spring version:  Default

- . Templates:
= Plug-in Development ~ v (> Simple Projects
5 Senver [Zy Simple Java
_k_b . [ Simple Spring Maven
W E—b SFI rnng [ Simple Spring Web Maven
. . . . (= Batch
@’ Spring Bean Configuration File & GemFire
@ Spring Bean Definition & Integration
. . = Persistence

@ Sp‘rlng LEQEC};" prﬂ‘_lECt %E, Simple Spring Utility Project

S Spring Web Flow Definition File GBS e T
[‘L—b Spnng Boot & requires downloading Configure templates... | Refresh
[= S0L Development Description:
- A new Spring MVC web application development project

= Tasks
_k U Aesi URL:https://dist.springscurce.com/release/5TS/help/org.springframework templates.mve-3.2.2 zip
= User Assistance
E_b Web hd Working sets
[[] Add project to working sets Mew...
Select.

® < Back Finish Cancel

@ < Back st Cancel




java.lang.java.lang.ExceptionininitializerError

i@ New Spring Legacy Project O X

Spring Legacy Project —

(i) Click 'Next' to load the template contents, ; "

Project name: | SpringHello |

Use default location

Lacation: | C:\Users\park\eclipse-workspace\aj22\SpringHello Browse... Eclipse jee_2021 _1 2 &

Select Spring version: | Default

— openjdk17 AFZ A

w [= Simple Projects

R Smple o Spring Legacy Project ¢

[& Simple Spring Ma o = |
[% Simple Spring Wel 8] Problem Occurred - - =) % L K-Il
= Batch .
= GemFire I:@;I An error has occurred, See error log for more details. => XI. H I. H_I x—l %
- —
= Integraticn = java.lang.ExceptionininitializerError

(= Persistence 1 H
%L—% Eim.F'Ie Spring UFiIit_v _OK Details »» Op?njdk;l 70-” A-I Jdk1 1 E
[& Spring MVC Project | Lil- —T‘.I OI: onl.

3 requires downloading

Configure templates... | Refresh
Description:

A new Spring MVC web application develepment project

URL:https://dist.springsource.com/release/5T5/help/erg.springframework.templates.mve-3.2.2.zip

Working sets
|:|Add project to werking sets Mew...
Working sets: Select...

® < Back Finish Cancel




java.lang.java.lang.ExceptionininitializerError

B cclipse.ni - Notepad C:\Users\park\eclipse\jee-2021-12\eclipse\eclipseiini & *
File Edit Format View Help
-startup

plugins/org.eclipse.equinox.launcher_1.6.480.v28218924-8641. jar

--launcher.library
C:h\Usershpark’.p2\poolipluginsiorg.eclipse.equinox.launcher.win32. . win32.x36 64 1.2 488 . v20211117-8658
-product

org.eclipse.epp.package. jee.product

-showsplash

C:h\Usershparkh.p2\poolipluginshorg.eclipse.epp.package.common_4.22.8.202112682-1268
--launcher.defaultAction

openFile

--launcher.appendVmargs

-wm
C:%Program Files\Java'jdk-11.8.2bin
S

-Vmargs
-Dosgi.requiredlavaVersion=11
-Dosgi.instance.area.default=@guser.home/eclipse-workspace

-Dsun. java.command=Eclipse

-2 :+UseGliGC

-¥¥:+UseS5tringDeduplication

--add-modules=ALL -SYSTEM

-Dosgi.requiredlavaVersion=11

-Dosgi.datalreaRequiresExplicitInit=true

-Dorg.eclipse.swt.graphics.Resource.reportlonDisposed=true

-Xms256m

-Xmx2848m

--add-modules=ALL-SYSTEM

-Declipse.p?.max.threads=18

-Doomph .update.url=https://download.eclipse.org/oomph/updates/milestone/latest

-Doomph . redirection. index.redirection=index:/-»http://git.eclipse.org/c/oomph/org.eclipse.comph.git/plain/setups/




Eclipse Spring Legacy Project

O Spring Legacy Project -> Spring MVC Project ->
package name -> Finish

@ New Spring Legacy Project O X
Project Settings - Spring MVC Project E‘—»
&
efine project specific settings. Required settings are denoted by "*".
edify th m

kr.ac.dankook.SpringHellg




Eclipse Spring Legacy Project

E.] Properties for SpringHello O
‘type filter text Project Facets i
Java Build Path A . .
Configuration: | <custom> v Save As... Delete
Java Code Style
Java Compiler Project Facet Version Details Runtimes
Javadoc Location [[]E Axis2 Web Services ElApache Tomcat v9.0
Java Editor [ ]E CXF 2.x Web Services 1.0
JSP Fragment [v]@ Dynamic Web Module 40 -
Maven [v]& Java 11 v
Project Facets [ ]2 JavaScript 1.0
Project Natures [ ] & JavaServer Faces 2.3 -
Project References [ ]2 JAX-RS (REST Web Services) 1.1 -
Run/Debug Settings [ ]+ JAXB 2.2 M
Server L]+ JPA 22 ’ (] Show all runtimes
Service Policies D 2 WebDoclet (XDoclet) 123 -~
Spring Make Primary New...
Targeted Runtimes Runtime compaosition:
Task Repository <no runtime selected>
Task Tags
Validation
Web Content Settings ,
< > Revert Apply

@ Apply and Close Cancel




Eclipse Spring Legacy Project

i@ Properties for SpringHello ] X

X || Java Build Path T

Java Build Path A

® Source & Projects =t Libraries % Order and Export @ Module Dependencies
JARs and class folders on the build path:

» Java Code Style
> Java Compiler

Javadoc Location - Modulepath Add JARs...
i > B JRE System Library [JavaSE-11
> Java Editor M Y vl ] Add External JARs...
JSP Fragment [« % Classpath
5 Maven > = Maven Dependencies Add Variable...
Project Facets \> = Server Runtime [Apache Tomcat v9.0] ]

Project Natures

Project References Add Class Folder...

Run/Debug Settings Add External Class Folder...
Server
Service Policies Edit...

» Spring Remove
Targeted Runtimes

» Task Repository Migrate JAR File...
Task Tags

> Validation v

< i T

@ Apply and Close Cancel




Spring MVC Project

o Spring MVC Project C|&E2| =X

v 23 SpringHello
» Deployment Descriptor: SpringHello
» A Spring Elements
v A JAK-WS Web Services
» [ src/main/java
» ¥ sre/main/resources
> ([ srcftest/java
» i src/test/resources
» Bk JRE System Library [JavaSE-1.6]
> B Maven Dependencies

» Eg Deployed Resources X|-|:||- _-?l_E El E_'l! E El
’ v [‘;;:Cmain ’
v [= java
w = kr
B 222 ClAED
HomeContr : . <
» gresgurces / V|eW JS, CSS
v =2 webapp —_—
(= resources o © o|x . )
v 8 s A2 ?I8t Spring A E
classes J
v (25 spring ——— h
vr‘éﬁp%rﬁt . Spring MVC configuration
servlet-context.xm — J
@5, root-contextxml r . )
ome.jsp
[H] webxml  c—— . . .
s e test &7 configuration file
» [ target J

[ pomaml T——

H O£ configuration file

—L




pom.xml ¢§ pom.xml

<properties>
<java-version>11</java-version>
<org.springframework-version>5.2.8. RELEASE</org.springframework-version>
<org.aspectj-version>1.6.10</org.aspectj-version>
<org.slf4j-version>1.6.6</org.slf4j-version>
</properties>
<build>
<plugins>
<plugin>
<groupld>org.apache.maven.plugins</groupld>
<artifactld>maven-compiler-plugin</artifactld>
<version>3.8.1</version>
<configuration>
<source>11</source>
<target>11</target>
<compilerArgument>-Xlint:all</compilerArgument>
<showWarnings>true</showWarnings>
<showDeprecation>true</showDeprecation>
</configuration>
</plugin>

Eclipse Project -> Maven -> Update Project (Update Maven)



pOm.XmI 'Jlk—xo-I pom.xml

<!-- https://mvnrepository.com/artifact/org.apache.maven.plugins/maven-war-plugin -->
<plugin>
<groupld>org.apache.maven.plugins</groupld>
<artifactld>maven-war-plugin</artifactld >
<version>3.3.1</version>
</plugin>
</plugins>
</build>

Eclipse Project -> Maven -> Update Project (Update Maven)



home.jsp +78

<%@ page language= Java” contentType="text/htmi; charset=UTF-8"
pageEncoding="UTF-8"%>

<%@ taglib uri="http.//java.sun.comy/jsp/jstl/core” prefix="c" %>
<%@ page session="false"” %>

<html>

<head>

<title>Home</title>

</head>

<body>

<h1>

Hello world!

</h1>

<P> The time on the server is ${serverTime}. </P>
</body>
</html>

home.jsp

Eclipse Project -> Run As -> Maven Clean & Maven Install & Run on Server




Spring MVC Project &

im] a Home X —|— -

C &) () localhost:8090/dankook/ A @ g v 3 =

Hello world!

The time on the server is 20223 58 13 @78 10A| 372 462 KST.



HomeController.java 7

@Controller HomeController.java

public class HomeController {
private static final Logger /ogger = LoggerFactory.getLogger(HomeController.class);

@RequestMapping(value = "/", method = RequestMethod. GET)

public String home(Locale locale, Model model) {

logger.info("Welcome home! The client locale is {}.", locale);

Date date = new Date();

DateFormat dateFormat = DateFormat.getDate Timelnstance(DateFormat.LONG,
DateFormat.LONG, locale);

String formattedDate = dateFormat.format(date);
model.addAttribute("serverTime", formattedDate ); ]
// add more attribute serverTimeZl message
String greetings = "Greetings, Spring MVC"; &Moo 2Eo FyHE
model.addAttribute("message”, greetings);
return "home";

}




home.jsp +=&

<%@ page language="java" contentType="text/html; charset=UTF-8"
pageEncoding="UTF-8"%>

<%@ taglib uri="http.//java.sun.comy/jsp/jstl/core” prefix="c" %>
<%@ page session="false"” %>

<html|>

<head>

<title>Home</title>

</head>

<body>

<h1>

Hello world! ${message}

</h1>

<P> The time on the server is ${serverTime}. </P>
</body>
</html>

home.jsp

Eclipse Project -> Run As -> Maven Clean & Maven Install & Run on Server




Spring MVC Project &

ﬂj D Home X + a = X
C () (D localhost:8090/dankook/ A @ T8 v 3 B -

Hello world! Greetings, Spring MVC

The time on the server is 20224 5& 13 @75 10A| 40& 147 KST.



HandlerMapping HandlerAdapter Controller

2 HEZp AM 3.UEEYHN 2% | ' N

Web ' . 4. Al A (Model&View) Fhet

e .
1L.28 .| :DispatcherServlet
Browser
5. Y 44 8% 55 244
View ViewResolver

jsp



2= MvC 2% 2P

o web.xmlO|| DispatcherServiet 278
s Ol ZZ M0 o 7| S(HEZD) STt Aol

o webxml O 75 QI2E EH 28

o AT MyCc Ad™ IR AESAE
<mvc:annotation-

= HandlerMapping, HandlerAdapter @8===| o -0 o=
= ViewResolver 878 AP 3=}

ﬂ java 278 AFEA|
@EnableWebMvc

jsp mE ddot=H AHE

@Controller Ef1
2t 5t



DispatcherServiet 27

n WEate ol 23 )
LOLS 0| ALY ZE|O|L{S A4

s ZAH|O|H A™ ot 2= /WEB-INF/Al S &l 0| S-servlet.xmlO|

7| = ’5785.:.'
» 28 O 258 UE7| |ISM = contextConfiglocation

<!-- Processes application requests -->
<servlet>
<servlet-name>appServlet</servlet-name>

web.xml

<servlet-class>org.springframework.web.servlet.DispatcherServlet </servlet-class>

<init-param>
<param-name>contextConfigLocation</param-name>

<param-value>/WEB-INF/spring/appServlet/serviet-context.xml</param-value>

</init-param>
<load-on-startup>1</load-on-startup>
</servlet>



http://localhost:8080/hello

DispatcherServiet 27

O servlet-context.xml 20l

servlet-context.xml

<!-- DispatcherServlet Context: defines this servlet's request-processing
infrastructure -->

<!-- Enables the Spring MVC @Controller programming model -->
<annotation-driven />

<!-- Handles HTTP GET requests for /resources/** by efficiently serving up static
resources in the ${webappRoot}/resources directory -->
<resources mapping= "/resources/**" location="/resources/” />

<!-- Resolves views selected for rendering by @Controllers to .jsp resources in the
/WEB-INF/views directory -->

<beans:bean

class= "org.springframework.web.serviet.view.InternalResourceViewResolver">
<beans:property name= "prefix" value="/WEB-INF/views/" />
<beans:property name= "suffix" value="/sp" />

</beans:bean>

<context:component-scan base-package= "krac.dankook” />



o web.xml2| webapp Ef1 L{O|| Ct= L& =7t

<filter>
<filter-name>encodingFilter</filter-name >
<filter-class>org.springframework.web filter.CharacterEncodingFilter</filter-class>
<init-param>
<param-name>encoding</param-name>
<param-value>UTF-8</param-value>
</init-param>
</filter>
<filter-mapping>
<filter-name>encodingFilter</filter-name>
<url-pattern>/*</url-pattern>
</filter-mapping>



MVC 424 E% (servlet-context.xml)

0 HandlerMapping, HandlerAdapter, ViewResolver 273
o WS O OfEE AMS2 L2 2 of &
s @Controller {=H|O|E|E S22 E HEEE AIEY = UL E

<!-- Enables the Spring MVC @Controller programming model -->
<annotation-driven />

!

[ot

servlet-context.xml

o 7 2|EH = OfdllE Soll ¢
= /web-inf/views/ Ot2f{Q] jsp LWUESS FHE ALE

=
<!-- Resolves views selected for rendering by @Controllers to .jsp resources
in the /WEB-INF/views directory -->
<beans:bean
class= "org.springframework.web.serviet.view./InternalResourceViewResolver">
<beans:property name= "prefix" value="yWEB-INF/views/" />
<beans:property name= "suffix" value=";sp" />
</beans:bean>



=d| 42 | EI2Y) (web.xml)

O A'—_Q_X|-7|- _9_*4‘6'—2 E% 74;0-” EH'(')'H appServlet Al__g_
« *do 9 20| FHKIE 7|5E Syt B
= /users/* @ 20| AEO| 0|ECE 7|58 Sltst= AL
St E_

Cts RE= MM 20 CHl| appServlet2 S&st S

jsp 282 7(1|52|°F LIHX| 2= 28 & appServletO]| 20=0[A| &
ATel mye A™EOA Y <mvcdefault-servlet-handler />=
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<servlet-mapping>
<servlet-name>appServlet</servlet-name>

<url-pattern>/</url-pattern>
</servlet-mapping>
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@Controller 0{-E{|0|M

HomeController.java

public class HomeController {
private static final Logger /ogger = LoggerFactory.getLogger(HomeController.class);

@RequestMapping(value = "/", method = RequestMethod. GE7) A= 0OHE
public String home(Locale locale, Model model) {

logger.info("Welcome home! The client locale is {}.", locale);

Date date = new Date();

DateFormat dateFormat = DateFormat.getDate Timelnstance(DateFormat.LONG,
DateFormat.LONG, locale);

String formattedDate = dateFormat.format(date);

model.addAttribute("serverTime", formattedDate ); 2 a0 cllo[e F7t
// add more attribute serverTimel} message
String greetings = "Greetings, Spring MVC"; — &Mo| 2Hlo] E=7HE
model.addAttribute("message", greetings);

J—

return "home"; & 0O|E Z|E

}



